Issues

  • Road works is not updated anymore? Returned data is years old.

    https://api.at.govt.nz/v2/locations/scheduledworks I tested it on API test page. It returns records before 2017. It looks like it's not maintained anymore? Or I missed a parameter?

    Status: Proposed | Reported by Hidden Wed, 24 Mar 2021 09:06:24 GMT
  • Ferry location api returns 502 when called in Python or Go but not via Curl or the Web UI

    As per the title. Tried setting the User-Agent to "curl/7.58.0" in both Go and Python but no dice. Same 502 error. Curl: curl https://api.at.govt.nz/v2/public/realtime/ferrypositions --http1.1 -H 'Ocp-Apim-Subscription-Key:$api_key' {"status":"OK","response":[{"mmsi":512000027... Python: >>> import requests >>> r = requests.get("https://api.at.govt.nz/v2/public/realtime/ferrypositions", headers={"Ocp-Apim-Subscription-Key": "$api_key"}) >>> r.status_code 502 >>> r.content b'<html><head><title> Server Error </title></head><body>\r\n <font color="\\&quot;#aa0000\\&quot;">\r\n <h2>Server Error.</h2>\r\n </font>\r\n\r\n There was an unexpected error in the request processing.\r\n </body></html>'

    Status: Proposed | Reported by Hidden Tue, 16 Feb 2021 07:07:17 GMT
  • Can't tell difference between ferries and buses

    Sorry, but I've just started with this API. I have it worked excellently well - nice work ! - except I don't see how to tell the difference between a bus and a ferry. I am producing a real time map and would like to have ferry icons for the ferries in the harbour, and bus icons for buses on the road. Is there any way I can tell ? I can't find any documentation ... if there is, please point me to it ! Cheers ! Simon

    Status: Proposed | Reported by Hidden Thu, 04 Feb 2021 07:18:32 GMT
  • v1 vehicle locations is broken

    Hi, the vehicle locations endpoint is not returning any entities, however the v2 is. I need the v1 api because it has the route information joined to it, where the v2 does not

    Status: Proposed | Reported by Hidden Mon, 14 Dec 2020 00:56:23 GMT
  • https://api.at.govt.nz/v2/public/realtime/ferrypositions

    Hi Is there a way to match the response from the Ferry location API to routes/trips in the GTFS? If not, is there another feed for ferry real time information? Thank you

    Status: Proposed | Reported by Hidden Mon, 26 Oct 2020 18:14:42 GMT
  • AT HOP fare info

    Hi Is there a source for geographical zone boundaries or a mapping of stop-to-zone that is available through the open data? Thanks!

    Status: Proposed | Reported by Hidden Tue, 20 Oct 2020 05:56:57 GMT
  • Vehicle Positions not showing

    Hi, when I ask for vehicle positions using a valid vehicle ID (eg: 31566), the response has no information: { "status": "OK", "response": { "header": { "timestamp": 1601500045.482, "gtfs_realtime_version": "1.0", "incrementality": 0 }, "entity": [] }, "error": null } I have tried with several vehicle IDs from other APIs in the suite.

    Status: Proposed | Reported by Hidden Wed, 30 Sep 2020 21:10:50 GMT
  • Parent stations - GTFS

    The GTFS stop file contains parent stops - is there a reason for these? How should we use this information? Thanks!

    Status: Proposed | Reported by Hidden Mon, 22 Jun 2020 13:11:17 GMT
  • HTTP/2 stream 1 was not closed cleanly: PROTOCOL_ERROR (err 1)

    Hi, The API seems to having some sort of problem - here's some curl output: curl -vv https://api.at.govt.nz/v2/gtfs/routes -H "Ocp-Apim-Subscription-Key:REDACTED" * Trying 137.116.141.180... * TCP_NODELAY set * Connected to api.at.govt.nz (137.116.141.180) port 443 (#0) * ALPN, offering h2 * ALPN, offering http/1.1 * successfully set certificate verify locations: * CAfile: /etc/ssl/certs/ca-certificates.crt CApath: /etc/ssl/certs * TLSv1.3 (OUT), TLS handshake, Client hello (1): * TLSv1.3 (IN), TLS handshake, Server hello (2): * TLSv1.3 (IN), TLS Unknown, Certificate Status (22): * TLSv1.3 (IN), TLS handshake, Unknown (8): * TLSv1.3 (IN), TLS Unknown, Certificate Status (22): * TLSv1.3 (IN), TLS handshake, Certificate (11): * TLSv1.3 (IN), TLS Unknown, Certificate Status (22): * TLSv1.3 (IN), TLS handshake, CERT verify (15): * TLSv1.3 (IN), TLS Unknown, Certificate Status (22): * TLSv1.3 (IN), TLS handshake, Finished (20): * TLSv1.3 (OUT), TLS change cipher, Client hello (1): * TLSv1.3 (OUT), TLS Unknown, Certificate Status (22): * TLSv1.3 (OUT), TLS handshake, Finished (20): * SSL connection using TLSv1.3 / TLS_AES_256_GCM_SHA384 * ALPN, server accepted to use h2 * Server certificate: * subject: C=NZ; L=Auckland; O=Auckland Transport; CN=*.at.govt.nz * start date: Aug 12 00:00:00 2019 GMT * expire date: Oct 13 12:00:00 2021 GMT * subjectAltName: host "api.at.govt.nz" matched cert's "*.at.govt.nz" * issuer: C=US; O=DigiCert Inc; CN=DigiCert SHA2 Secure Server CA * SSL certificate verify ok. * Using HTTP2, server supports multi-use * Connection state changed (HTTP/2 confirmed) * Copying HTTP/2 data in stream buffer to connection buffer after upgrade: len=0 * TLSv1.3 (OUT), TLS Unknown, Unknown (23): * TLSv1.3 (OUT), TLS Unknown, Unknown (23): * TLSv1.3 (OUT), TLS Unknown, Unknown (23): * Using Stream ID: 1 (easy handle 0x55ef30205580) * TLSv1.3 (OUT), TLS Unknown, Unknown (23): > GET /v2/gtfs/routes HTTP/2 > Host: api.at.govt.nz > User-Agent: curl/7.58.0 > Accept: */* > Ocp-Apim-Subscription-Key:REDACTED > * TLSv1.3 (IN), TLS Unknown, Certificate Status (22): * TLSv1.3 (IN), TLS handshake, Newsession Ticket (4): * TLSv1.3 (IN), TLS Unknown, Certificate Status (22): * TLSv1.3 (IN), TLS handshake, Newsession Ticket (4): * TLSv1.3 (IN), TLS Unknown, Unknown (23): * Connection state changed (MAX_CONCURRENT_STREAMS updated)! * TLSv1.3 (OUT), TLS Unknown, Unknown (23): * TLSv1.3 (IN), TLS Unknown, Unknown (23): * TLSv1.3 (IN), TLS Unknown, Unknown (23): * HTTP/2 stream 1 was not closed cleanly: PROTOCOL_ERROR (err 1) * Connection #0 to host api.at.govt.nz left intact curl: (92) HTTP/2 stream 1 was not closed cleanly: PROTOCOL_ERROR (err 1) Also, https://dev-portal.at.govt.nz/developer seems to be taking about 40 seconds to load each page

    Status: Proposed | Reported by Hidden Tue, 25 Feb 2020 03:49:16 GMT
  • API returning blank responses for valid current trip ids

    The Realtime GTFS feed is returning blank entities for API calls with valid trip ids (i.e. trips that should be currently running)

    Status: Proposed | Reported by Hidden Sun, 23 Feb 2020 20:32:34 GMT

You're not signed in. Please sign-in to report an issue or post a comment.